2011 - 2012 Slidecasts / Webémissions

Flash Player 10.1 or newer is needed for the Adobe Presenter Slidecasts. You can check to see if your version of Flash is compatible at this link: http://conn-o.osapac.org/common/help/en/support/meeting_test.htm

Comment

You need to be a member of Mentoring / Mentorat to add comments!

#tllp on Twitter

© 2017   Created by TPSB   Powered by

Badges  |  Report an Issue  |  Terms of Service